Furniture Connect

Report a problemSubscribe to updates
Powered by
Privacy policy

·

Terms of service
Authentication Issues
Resolved·Partial outage

Fixed upstream

Thu, Feb 19, 2026, 07:03 PM
(4 months ago)
·
Affected components
Feb 19, 2026, 04:35 PM
07:03 PM
App
Updates

Resolved

Fixed upstream

Thu, Feb 19, 2026, 07:03 PM

Investigating

Upstream fix

Thu, Feb 19, 2026, 04:50 PM(2 hours earlier)

Investigating

Our upstream authentication provider is experiencing issues, you can track them here: https://status.clerk.com/

Thu, Feb 19, 2026, 04:35 PM(15 minutes earlier)